Cloud Beast tank not working on Alien 220w

Discussion in 'All Tanks / Factory Coils' started by jerbear1112, Dec 31, 2016.

  1. jerbear1112

    jerbear1112 New Member

    Blog Posts:
    0
    Joined:
    Dec 31, 2016
    Messages:
    2
    Reading a thread here, I saw members saying that they had cloud beast tanks working on Smok Alien 220w. So I decided to buy one and upgrade. Once I actually screwed the tank onto the mod, it never asked "new coil?" Or even recognized that a tank was connected. The ohms read 0.000 and I can't adjust them. It seems as though the tank is not grounding? The baby beast tank that comes stock with the alien has a smooth contact surface where as the cloud beast has a groove cut in. The cloud Beast threaded post also seems longer. Is there some trick to making it work? Or did I just get a bastard tank? Any help is appreciated.
     
  2. Discobob

    Discobob Silver Contributor Member For 2 Years

    Blog Posts:
    0
    Joined:
    Mar 17, 2015
    Messages:
    1,047
    Did you try another coil? Might have a bad one. Maybe your 510 pin is stuck and not adjusting?
     
  3. jerbear1112

    jerbear1112 New Member

    Blog Posts:
    0
    Joined:
    Dec 31, 2016
    Messages:
    2
    Thanks man, that did it. The quad core coil in the tank from purchase wasn't working. I used the Q4 instead and it's all good
     
  4. Discobob

    Discobob Silver Contributor Member For 2 Years

    Blog Posts:
    0
    Joined:
    Mar 17, 2015
    Messages:
    1,047
    Yup the Q4 in mine worked but leaked.....bastards, like your gonna return the whole tank for a coil unless you bought local. The coils for smok have been kinda hit or miss lately.
     
  5. sychosis

    sychosis Silver Contributor Member For 2 Years

    Blog Posts:
    0
    Joined:
    Apr 22, 2015
    Messages:
    711
    Got 4 beasts , the q4 in everyone of them leaked the first time I primed and filled, took out , cleaned up and started vaping again and have not leaked since but for some odd reason every single one if them leaked like a sieve on the first fill

    Sent from my SAMSUNG-SM-G930A using Tapatalk
     
  6. Discobob

    Discobob Silver Contributor Member For 2 Years

    Blog Posts:
    0
    Joined:
    Mar 17, 2015
    Messages:
    1,047
    Weird, I tried to drain and refill and it leaked again, but not bad. Seemed once it leaked half way it was fine, kept it for last resort if needed:)
     
  7. sychosis

    sychosis Silver Contributor Member For 2 Years

    Blog Posts:
    0
    Joined:
    Apr 22, 2015
    Messages:
    711
    Maybe I just had good luck , I did blow them.into a paper towel.before I refilled , may or may not have anything to.do with it but 2 of the q4 I still have kicking for over a month

    Sent from my SAMSUNG-SM-G930A using Tapatalk
     
  8. RMVapes28

    RMVapes28 New Member

    Blog Posts:
    0
    Joined:
    Jan 8, 2017
    Messages:
    104
    I know this is a few weeks old since the last post but I just bought the alien with the cloud beast and have had no issues with any of the coils or any leaking whatsoever. Maybe I got lucky. For what I paid for it at a local shop it shouldn't leak!
     
    Carhauler71 likes this.

Share This Page

Close This Message