Help please

Discussion in 'General Requests' started by bx10r, Apr 23, 2017.

  1. bx10r

    bx10r Bronze Contributor

    Blog Posts:
    0
    Joined:
    Dec 19, 2016
    Messages:
    441
    Don't know what happened but I was on a build and when I started to post the fire button to fire my coils my mini stop working. all of a sudden I burned smell came out tried another battery and still won't power. literally just turned a month old today. Does anyone have any email or phone number for coilmaster I've tried Google but cannot find anything to see what warranty is. Any help is appreciated
     
  2. Markw4mms

    Markw4mms #Team Jimi Supporter Staff Member Senior Moderator VU Donator Diamond Contributor Member For 2 Years ECF Refugee

    Blog Posts:
    0
    Joined:
    May 20, 2015
    Messages:
    15,033
    SirRichardRear and bx10r like this.
  3. bx10r

    bx10r Bronze Contributor

    Blog Posts:
    0
    Joined:
    Dec 19, 2016
    Messages:
    441
    Never got notified of this. Thanks, i emailed them
     
  4. SirRichardRear

    SirRichardRear AKA Anthony Vapes on Youtube VU Donator Diamond Contributor Member For 1 Year Reviewer

    Blog Posts:
    0
    Joined:
    Jul 8, 2016
    Messages:
    11,305
    sounds like the chip fried. you weren't doing anything wrong I'd contact them for warranty.
     
    bx10r likes this.
  5. bx10r

    bx10r Bronze Contributor

    Blog Posts:
    0
    Joined:
    Dec 19, 2016
    Messages:
    441
    Nothing but a build on it. Nothing i havent done before
     
    SirRichardRear likes this.

Share This Page

Close This Message