1. THE VAPORJOES NETWORK IS GIVING AWAY A PLAYSTATION 4 PRO
    CLICK HERE FOR INFO

I need help with smok stick v8

Discussion in 'Regulated (Voltage / Wattage / 3.7v/ Temp Control)' started by drowsed123, Mar 19, 2017.

  1. drowsed123

    drowsed123 New Member

    Blog Posts:
    0
    Joined:
    Mar 19, 2017
    Messages:
    8
    I need help with my stick v8 from smok as I cannot call the long distance number. I charge the battery and the charging light goes off. So I turn it on and each time I try to vape the main indicator flashes.
     
  2. aquaholic2491

    aquaholic2491 Bronze Contributor

    Blog Posts:
    0
    Joined:
    Dec 26, 2016
    Messages:
    277
    you try disconnecting the tank and reconnecting it/?
     
  3. drowsed123

    drowsed123 New Member

    Blog Posts:
    0
    Joined:
    Mar 19, 2017
    Messages:
    8
    Many times
     
  4. PhantomOp

    PhantomOp VU Donator Gold Contributor Member For 1 Year

    Blog Posts:
    0
    Joined:
    Nov 5, 2016
    Messages:
    1,866
    How many blink are you getting?

    From their website ---
    "The battery life indicator will blink 4 times each time you take a puff. When it blinks fast with 15 times, it indicates that the voltage is lower than 3.3V"
    http://www.smoktech.com/kit/stick-v8
     
  5. drowsed123

    drowsed123 New Member

    Blog Posts:
    0
    Joined:
    Mar 19, 2017
    Messages:
    8
    it blinks 4 times when I try to vape and hold down the button and no smoke comes out
     
  6. PhantomOp

    PhantomOp VU Donator Gold Contributor Member For 1 Year

    Blog Posts:
    0
    Joined:
    Nov 5, 2016
    Messages:
    1,866
    OK, just to eliminate the obvious questions (not saying you haven't done them already, some have overlooked them)

    - Did you put juice in the atty (tank) ?
    - What coil is in the atty ?
    - Do you have a different atty you can put on it to test with ?
     
  7. drowsed123

    drowsed123 New Member

    Blog Posts:
    0
    Joined:
    Mar 19, 2017
    Messages:
    8
    Yes there juice in the tank. The coil is m2-0.25 ohms direct output by smok. I do not have a differbt tank but I have tried this tank on a different mod and it worked
     
  8. PhantomOp

    PhantomOp VU Donator Gold Contributor Member For 1 Year

    Blog Posts:
    0
    Joined:
    Nov 5, 2016
    Messages:
    1,866
    And I'm assuming that you get no crackling / sizzling sound when you hold down the fire button?

    Can you take a picture of the 510 connection on the MOD? Kinda like this --

    IMG_20170308_022548655 (Large).jpg
     
  9. PhantomOp

    PhantomOp VU Donator Gold Contributor Member For 1 Year

    Blog Posts:
    0
    Joined:
    Nov 5, 2016
    Messages:
    1,866
    Also a picture of the 510 pin on the atty. --- like this. I am specifically looking for the protrude / depth of the 510 pin on this picture.

    IMG_20170225_222229027 (Large).jpg
     
  10. drowsed123

    drowsed123 New Member

    Blog Posts:
    0
    Joined:
    Mar 19, 2017
    Messages:
    8
     

    Attached Files:

    PhantomOp likes this.
  11. drowsed123

    drowsed123 New Member

    Blog Posts:
    0
    Joined:
    Mar 19, 2017
    Messages:
    8
     

    Attached Files:

    PhantomOp likes this.
  12. PhantomOp

    PhantomOp VU Donator Gold Contributor Member For 1 Year

    Blog Posts:
    0
    Joined:
    Nov 5, 2016
    Messages:
    1,866
    Excellent! Thank you for the clear pictures.

    Your 510 on the MOD looks fine. The only thing to check is if the center pin can be pushed in. It should be spring loaded pin, so just press it in slightly (not a lot of pressure) and see if it moved up/down.

    Second. On that tank, the 510 pin looks good. The one issue that I've had with that atty is the pin can sometimes not make good contact with the coil (juice on it, dirty, etc). However, you said the atty works on another MOD without issue.

    The only thing left that you can check, is if you have a volt meter. The gold 510 center pin is the (+) positive post. The threading is the (-) negative post. If you have extra arms attached to your body you can do this trick yourself, otherwise you will need someone's assistance. You will need to hold the volt meter to each post and press the fire button --- you should have voltage on your volt meter, approx 3.2 ~ 3.7V
     
  13. drowsed123

    drowsed123 New Member

    Blog Posts:
    0
    Joined:
    Mar 19, 2017
    Messages:
    8
    It still does the same thing
     
  14. PhantomOp

    PhantomOp VU Donator Gold Contributor Member For 1 Year

    Blog Posts:
    0
    Joined:
    Nov 5, 2016
    Messages:
    1,866
    I'm not sure how long you have had your MOD or if it is brand new, but I would say that the MOD is defective / 510 pin is bad.
    You will have to warranty it or return it to the place of purchase if it is still in warranty.
     
  15. drowsed123

    drowsed123 New Member

    Blog Posts:
    0
    Joined:
    Mar 19, 2017
    Messages:
    8
    Ok thankyou for the attention/help
     
    PhantomOp likes this.
  16. PhantomOp

    PhantomOp VU Donator Gold Contributor Member For 1 Year

    Blog Posts:
    0
    Joined:
    Nov 5, 2016
    Messages:
    1,866
    Your welcome.

    @inspects @5150sick @lordmage

    Can you move this thread to the "Ask the Experts" section please. This is in the wrong section.
     
    Last edited by a moderator: Mar 20, 2017
  17. lordmage

    lordmage Joined The Crusade - it's PG/VG, not VG/PG!!! Staff Member Senior Moderator VU Donator Gold Contributor Member For 3 Years ECF Refugee

    Blog Posts:
    1
    Joined:
    May 18, 2014
    Messages:
    1,578
    moved to a more proper area
     
    PhantomOp likes this.
  18. Johnnytraveler

    Johnnytraveler Gold Contributor Member For 1 Year

    Blog Posts:
    0
    Joined:
    Sep 22, 2016
    Messages:
    1,780
    As simple as this device is, it's hard to believe you're having problems.

    1. You stated that you tested the tank on someone else's mod. Was this after the problem started or before?
    2. If you have an extra coil, install it and test again. Sometimes coils fail.
    3. You stated that it was fully charged, but not firing. Unfortunately you don't have an extra tank to verify if the mod is dead. If you can borrow a tank, (any tank) to test that would confirm it.
    4. It looks like below the usb port is a reset switch. Stick a pin in there to reset. Note: I don't own this mod, so you should review the owner's manual to confirm that the hole is for resetting.

    Sent from somewhere in Vietnam.
     
  19. 232323

    232323 New Member

    Blog Posts:
    0
    Joined:
    Feb 7, 2017
    Messages:
    47
    Hi, I know that this is what it says in the manual, however I have one of these and the light doesn't work the way the manual states.

    When I take a puff, the light stays on as long as I have my finger on the fire button.

    4 flashes appears to happen when a regulated mod would say "atomizer short/low" or "no atomizer".

    I had problems trying to use an rba on it which gave atomizer short/low message on other mods, and it also flashes 4 times if you try and fire it without a tank on it.

    I would also suggest trying another tank on it or putting a new coil in your tank. If neither of these work I'd be returning it, I think.
     
    Stephanie1112 and Bawk like this.
  20. techworks

    techworks New Member

    Blog Posts:
    0
    Joined:
    Jun 27, 2017
    Messages:
    1
    Hi, i had the same problem with Stick V8 Kit the battery life indicator blinks 4 times, checked comments here then replaced M2 coil with a new one it works again, Thank you!
     
    Stephanie1112 and The Huntress like this.
  21. MorganShay

    MorganShay New Member

    Blog Posts:
    0
    Joined:
    Jul 2, 2017
    Messages:
    1
    in the user manual it says when it blinks 4 times, there is a short circuit. mine is doing this now when i put in the second coil that came in the box (M-2 0.25 ohm)
     
  22. cwhart24

    cwhart24 New Member

    Blog Posts:
    0
    Joined:
    Jul 8, 2017
    Messages:
    1
    I'm not sure if you have fixed this yet but I was having the same problem and just cleaned where the power source makes contact with tank and it started working.
     
  23. Stephanie1112

    Stephanie1112 New Member

    Blog Posts:
    0
    Joined:
    Jul 30, 2017
    Messages:
    3

    I've had my smok stick v8 for about 3 weeks now.mine don't blink any after I take a hit.but yesterday it started blinking fast so I plugged it in thinking the battery needed charged.well now I had to plug it back in cause it was acting like it was dead again.I switched cords..actually 4 different ones.idk what's going on but I'm honestly scared of messing up the battery on a devise that I'm going to be holding & have next to my head.ithe is suppose to blink,or so I've read.maybe it's a defect with this one
     
  24. Just Frank

    Just Frank Silver Contributor

    Blog Posts:
    0
    Joined:
    Mar 17, 2017
    Messages:
    741
    I've had one for a few months and has been flawless. I love this little setup.
     
  25. Stephanie1112

    Stephanie1112 New Member

    Blog Posts:
    0
    Joined:
    Jul 30, 2017
    Messages:
    3
    I had no problems like this untill I put in
    a

    The only time I had this same problem was with the X-4 0.15 coils.The first time i put 1 of the 2 i purchased on it worked perfectly for about 3 hours.I then turned iff my stick,plugged it up & it wouldnt do anything but blink when i hit the fire button.not knowing what happened,I changed coils & it fired right up.the 2nd one I put in a lil later wouldn't do anything but make my v8 stick blink.maybe it just don't work goid with the stick kits.idk
     
  26. Stephanie1112

    Stephanie1112 New Member

    Blog Posts:
    0
    Joined:
    Jul 30, 2017
    Messages:
    3
    I love my v8 stick kit!this is actually my 4th smok purchase.I bought the smok pen plus,then a v8 stick then the regular pen 22 kit now this one.my newest one has been the only one to give me any problems.none enough to turn me from smok at all though.this one from day one though acts like it won't hit everytime & now the charge port seems to be kinda loose like..I have to "wiggle " the cord one the connection port end on the battery to get the charging indicator light to come on
     
  27. mohinder87

    mohinder87 New Member

    Blog Posts:
    0
    Joined:
    Aug 11, 2017
    Messages:
    1
    Hello, i had the same problem with my stick v8 baby, i fixed it just by loosen a little bit my atty, not perfect but it works
     
  28. figure8vapes

    figure8vapes New Member

    Blog Posts:
    0
    Joined:
    Aug 14, 2017
    Messages:
    2
    I had the same issue when i first got mine. I disassembled mine completely before using it to understand how it all went together, and when i put it all back together i screwed the coil in way too tight. if you unscrew the coil you'll notice the pin in the connector is loose so it can be adjusted. So i loosened the coil up and pressed the pin in so it protruded only a teeny tiny bit, and now i can screw the tank onto the battery nice tight and flush and it works. hope this helps you out too.
     
  29. figure8vapes

    figure8vapes New Member

    Blog Posts:
    0
    Joined:
    Aug 14, 2017
    Messages:
    2
    read my above reply. you screwed the coil in too tight
     
  30. melziemae

    melziemae New Member

    Blog Posts:
    0
    Joined:
    Jul 22, 2017
    Messages:
    22
    Try disconnecting the base from the battery. Take out your coil, take a Q tip w/rubbing alcohol and clean all around, the inside, and the bottom side. THEN- push on the 510 connector of your base, put your coil back in while holding onto the outer edge of the 510 pin. Then take a mini screwdriver and tighten your 510 in position. It should protude just a bit. If you 510 pin isn't properly connecting to the receiver on the battery, it won't hold a charge.
     
  31. Just Frank

    Just Frank Silver Contributor

    Blog Posts:
    0
    Joined:
    Mar 17, 2017
    Messages:
    741
    I got a couple more!
    0816171413-1(1).jpg
    Someone already said to me "Wow, are you taking that thing duck hunting?"
     
    wildgypsy70 likes this.
  32. Hypnoticvix

    Hypnoticvix New Member

    Blog Posts:
    0
    Joined:
    Aug 20, 2017
    Messages:
    1
    I just experienced this like 10 mins ago, I just took the whole tank apart. Cleaned everything. Once I did that and put the tank back on, its been working fine since If someone has said this already, I am sorry. Not taking the time to read responses. Just the question.
     
  33. jacksvaping

    jacksvaping New Member

    Blog Posts:
    0
    Joined:
    Aug 27, 2017
    Messages:
    1
    I recently bought a Smok V8 and it's not holding a charge. Everything works as it should when it's connected to the charger, but won't work at all if I disconnect it, simply blinks 4 times. Again, everything works fine while plugged in, but not when I unplug. What can the issue be?
     
  34. SkoldVape

    SkoldVape Gold Contributor

    Blog Posts:
    0
    Joined:
    Apr 10, 2017
    Messages:
    1,570
    If I was you I'd take it to where you got it, that's if you got it from a shop.
    I know at my local there were some faulty vape pen 22s and same with V8 stick. You'll get a refund as it is down to a fault with the battery, it is not something you've done wrong
     
  35. Quintinium

    Quintinium New Member

    Blog Posts:
    0
    Joined:
    Oct 14, 2017
    Messages:
    1

    Hey, just a little FYI, you sure helped me. It's new mod for me, and I put in a brand new atomizer and it didn't work. The pics the other guy sent and your comments led me realize it was my atomizer. Thanks.
     

Share This Page

Close This Message