1. THE VAPORJOES NETWORK IS GIVING AWAY A PLAYSTATION 4 PRO
    CLICK HERE FOR INFO

Smok Big Baby Beast, Smok Alien, and RBA "short" issues.

Discussion in 'All Tanks / Factory Coils' started by Mebejedi, Mar 25, 2017.

  1. Mebejedi

    Mebejedi Member For 2 Years

    Blog Posts:
    0
    Joined:
    Oct 8, 2014
    Messages:
    83
    Don't know if this has been brought up, but I've discovered an issue with the RBA contacts in my BBB.

    If you look at the base of the RBA, there's a wide bar that makes contact with the firing pin. What I've discovered is that when the Tank is screwed together tightly, this bar is pushed down so far as to make contact with both the pin AND the surrounding base, causing a short. I've never encountered this with coils, but since I prefer the RBA, I've had occasional issues when putting in new coils. Looking at the bar and inside the base of the mod where it screws in, I can see a small black burn mark on both. Doing some research, another person said most of the bar and the base on their BBB was black. Basically, I cannot screw the tank together as tightly as I normally would, as too much pressure from the chimney to the RBA would push the underlying bar too far down. I'd show you a picture of the burn marks, but I don't want to disassemble the tank again because it's working now.

    Here's the Reddit link where I got the info: https://www.reddit.com/r/electronic...psa_tfv8_baby_beast_coilbase_shorting_issues/

    At some point, I guess I will lightly grind down the edges of the bar to prevent contacts in the future.

    That is all.
     
    gakudzu likes this.
  2. gakudzu

    gakudzu Gold Contributor Member For 1 Year

    Blog Posts:
    0
    Joined:
    Oct 6, 2016
    Messages:
    2,392
    Cheese whiz :facepalm:
    He found the problem by putting a shorting atty on a mech. Damn lucky he didn't blow his stupid ass up.
     
  3. Mebejedi

    Mebejedi Member For 2 Years

    Blog Posts:
    0
    Joined:
    Oct 8, 2014
    Messages:
    83
    A Smok Alien isn't a mech. ;)

    [EDIT] Oh, you mean the other guy.
     
  4. gakudzu

    gakudzu Gold Contributor Member For 1 Year

    Blog Posts:
    0
    Joined:
    Oct 6, 2016
    Messages:
    2,392
  5. DanzBorin

    DanzBorin New Member

    Blog Posts:
    0
    Joined:
    Feb 14, 2017
    Messages:
    21
    Any idea if this same issue happens with a TFV8? I've been having all kinds of issued with mine. I can't see any issue with shorting on the coils or the outer sleeve, but keep getting "Do not abuse" message with a crazy high resistance reading or "Resistance Too Low" with 0.00 resistance reading. They seem to go from one to the other while screwing/unscrewing and telling it that it's a new coil...
     
  6. gakudzu

    gakudzu Gold Contributor Member For 1 Year

    Blog Posts:
    0
    Joined:
    Oct 6, 2016
    Messages:
    2,392
    It could be that the base of the coil isn't screwed tightly into the body of the coil. That happened on one of mine, and caused it to do what you describe. I didn't even realise it was threaded in, until it came loose.
     
  7. DanzBorin

    DanzBorin New Member

    Blog Posts:
    0
    Joined:
    Feb 14, 2017
    Messages:
    21
    I'll give it a whirl, but I think it's good... :shrugs:
     
  8. MarkS

    MarkS Silver Contributor Member For 2 Years

    Blog Posts:
    0
    Joined:
    Jan 14, 2015
    Messages:
    1,451
    I've heard of people needing to do a little bit of filing or grinding on the RBA for that very reason.


    Sent from my iPhone using Tapatalk
     
    gakudzu likes this.
  9. DanzBorin

    DanzBorin New Member

    Blog Posts:
    0
    Joined:
    Feb 14, 2017
    Messages:
    21
    On the bottom portion?
     
  10. MarkS

    MarkS Silver Contributor Member For 2 Years

    Blog Posts:
    0
    Joined:
    Jan 14, 2015
    Messages:
    1,451
    Yes


    Sent from my iPhone using Tapatalk
     
  11. DanzBorin

    DanzBorin New Member

    Blog Posts:
    0
    Joined:
    Feb 14, 2017
    Messages:
    21
    Thanks, I'll give it a whirl!
     
  12. DanzBorin

    DanzBorin New Member

    Blog Posts:
    0
    Joined:
    Feb 14, 2017
    Messages:
    21
    IMG_5661.JPG IMG_5662.JPG First shot is after screwing into the Alien with no coil on. Shows how far it pushes in the pin. Second shot shows after I screwed in the RBA. That's how far it pushed the pin out.

    Would I have to remove approx that much from the bottom of the RBA? If so, would that potentially mess up the RBA for use on other mods?
     
  13. MarkS

    MarkS Silver Contributor Member For 2 Years

    Blog Posts:
    0
    Joined:
    Jan 14, 2015
    Messages:
    1,451
    If I recall correctly, it's not the bottom that is shorting but rather the two ends (corners) of the RBA positive protrusion/pin. If there is enough "meat" on the bottom of the RBA positive protrusion/pin you may try taking just a little off of it being careful to not take too much and make it too weak.
     
  14. DanzBorin

    DanzBorin New Member

    Blog Posts:
    0
    Joined:
    Feb 14, 2017
    Messages:
    21
    Where I have circled?

    Should the 510 pin be in contact with the short protrusion on the bottom of the RBA? That's what's forcing the pin out when I screw in the RBA.
     

    Attached Files:

  15. MarkS

    MarkS Silver Contributor Member For 2 Years

    Blog Posts:
    0
    Joined:
    Jan 14, 2015
    Messages:
    1,451
    Yes and yes. I would round off the corners a bit where you have circled. The 510 pin sticking out isn't the problem, in fact it's good to have decent clearance or distance. The pin is the positive and the threads are the negative (on the RBA, Base, and 510 connectors).
     
    Last edited: Apr 27, 2017
  16. DanzBorin

    DanzBorin New Member

    Blog Posts:
    0
    Joined:
    Feb 14, 2017
    Messages:
    21
    Sounds like dremel time! Thanks for the help! I'll report back.
     
    MarkS likes this.
  17. MarkS

    MarkS Silver Contributor Member For 2 Years

    Blog Posts:
    0
    Joined:
    Jan 14, 2015
    Messages:
    1,451
    I don't have my Big Baby with me to look at. I would use the bottom of the pre-made coils as a go by since they work without a problem. Just go easy with the Dremel Tool... you can always take a little more off but once it's off, it's off.
     
  18. DanzBorin

    DanzBorin New Member

    Blog Posts:
    0
    Joined:
    Feb 14, 2017
    Messages:
    21
    Measure twice cut once. ;)

    This is a Cloud beast, but same theory. Sadly I have no coils for comparison. I have some on the way though. I can wait it out.
     
  19. triakis

    triakis Member For 1 Year

    Blog Posts:
    0
    Joined:
    May 4, 2016
    Messages:
    128
    I've had issues with the big baby beast included RBA. If it's screwed in TIGHT it will definitely short out. Do NOT use this on a mech or other device with output protection! Aside from that, it vapes great.
     
  20. DanzBorin

    DanzBorin New Member

    Blog Posts:
    0
    Joined:
    Feb 14, 2017
    Messages:
    21
    I'm at a loss. Nothing will work. On my alien I get a short no matter what coil I'm using. Q4, short... T8, short... RBA short... When I put on the 213 plus works fine. My Alien works fine with RDAs, all other tanks I have (2 big babies and a baby, all work fine). I don't get what's going on.
     
  21. MarkS

    MarkS Silver Contributor Member For 2 Years

    Blog Posts:
    0
    Joined:
    Jan 14, 2015
    Messages:
    1,451
    Have you tried measuring the resistance between the positive pin and the threads on the Mod while depressing the pin to see what happens?


    Sent from my iPhone using Tapatalk
     
  22. DanzBorin

    DanzBorin New Member

    Blog Posts:
    0
    Joined:
    Feb 14, 2017
    Messages:
    21
    I am a complete dolt as far as electricity goes. No idea how to do that.
     
  23. MarkS

    MarkS Silver Contributor Member For 2 Years

    Blog Posts:
    0
    Joined:
    Jan 14, 2015
    Messages:
    1,451
    Sorry... It would take you having an ohm meter with leads. How about triggering/firing the Mod with no Atty on it and pressing the positive pin further down to see if it suddenly shows short at some point (being careful that you don't cause the short).


    Sent from my iPhone using Tapatalk
     
  24. DanzBorin

    DanzBorin New Member

    Blog Posts:
    0
    Joined:
    Feb 14, 2017
    Messages:
    21
    What would I press it down with?
     
  25. MarkS

    MarkS Silver Contributor Member For 2 Years

    Blog Posts:
    0
    Joined:
    Jan 14, 2015
    Messages:
    1,451
    You could use a small screwdriver, pen, or anything small enough to reach the center pin of the Mod without touching the threads.


    Sent from my iPhone using Tapatalk
     
  26. DanzBorin

    DanzBorin New Member

    Blog Posts:
    0
    Joined:
    Feb 14, 2017
    Messages:
    21
    Maybe I'm misunderstanding, but that just says no coil the whole time...
     
  27. MarkS

    MarkS Silver Contributor Member For 2 Years

    Blog Posts:
    0
    Joined:
    Jan 14, 2015
    Messages:
    1,451
    Good! Eliminates Mod faulting. I'm stumped a little too... Have a few ideas but hard to explain.


    Sent from my iPhone using Tapatalk
     
  28. zook

    zook New Member

    Blog Posts:
    0
    Joined:
    Jun 27, 2017
    Messages:
    1
    Cant screw tank together all the way tight. Pin pops out if so...so far so good but not ideal..
     
  29. jfdibutton

    jfdibutton Member For 2 Years

    Blog Posts:
    0
    Joined:
    Apr 26, 2015
    Messages:
    78
    I have found that if I screw the rba onto the bottom of the chimney then the base onto the rba it helps. You may get away with just doing that. I also took the Dremel to the bottom of the rba not just the corners but clear across. And put them together as stated above and combining these two steps haven't had any more issues.

    There are 2 problems with the rba base. The threads allow it to screw into the base further than the stock coils and it is slightly taller than the stock coils.
     
  30. missuzsmith

    missuzsmith New Member

    Blog Posts:
    0
    Joined:
    Oct 8, 2017
    Messages:
    1
    I'm having problems with BOTH of the Aliens I purchased, one about 2 months ago and the other just about 3 weeks ago. Ridiculous for the amount of money I have spent. On the older one it's just not working, looks like it's firing but no heat whatsoever. On the newer one I'm getting the Atomizer Too Short and Don't Abuse Protects messages. I tried all the basics, taking out batteries, firing up and selecting Yes for new coil. I'm not handy with tools and other technical things beyond. I ordered a new IPV8 as my IPV2 didn't have these issues. Are Alien's just pieces of junk???
     
  31. SkoldVape

    SkoldVape Silver Contributor

    Blog Posts:
    0
    Joined:
    Apr 10, 2017
    Messages:
    1,276
    I actually love my Alien but my first one the screen just went completely dead, I think that so many are mass produced makes them hit an miss. I think Smok mods are really good for wattage mode but they have QC issues. Personally all my smok mods have been flawless. Only issue I've ever had is my first alien.
    I got the don't abuse protects message too btw but that's a message telling you not to fire the mod without an atomizer attached. It should not just come up with the message at random.
    I definitely don't think they are garbage though cos when they work they are great.
    I've had this one for a year!
     
  32. Steve St

    Steve St New Member

    Blog Posts:
    0
    Joined:
    Aug 29, 2017
    Messages:
    28
    Did you use the other glass that comes with the rba, this glass is taller than the glass for the stock coils, that may be why it's screwing too far down in the base and shorting out.
     
    SkoldVape likes this.
  33. SkoldVape

    SkoldVape Silver Contributor

    Blog Posts:
    0
    Joined:
    Apr 10, 2017
    Messages:
    1,276
    The coils that come with the RBA are known too short out, it's a common issue.
    I'd suggest putting your own build in, loads of people had issues with the claptons that come installed for some reason.
     
  34. lcgixxer87

    lcgixxer87 Bronze Contributor Member For 2 Years

    Blog Posts:
    0
    Joined:
    Apr 7, 2015
    Messages:
    353
    I'm having issues with these same messages on my alien. Random don't abuse protects and atomizer short messages. I've got a brand new Merlin rdta on it. I did everything I could with the atty and it just comes at random


    Sent from my iPhone using Tapatalk
     
  35. SkoldVape

    SkoldVape Silver Contributor

    Blog Posts:
    0
    Joined:
    Apr 10, 2017
    Messages:
    1,276
    My first alien did it but had my replacement for a year an it's not done it once. I think the alien is hit an miss but my osub 80w does it as well & it's so annoying
     
  36. lcgixxer87

    lcgixxer87 Bronze Contributor Member For 2 Years

    Blog Posts:
    0
    Joined:
    Apr 7, 2015
    Messages:
    353
    Will smok swap it out or no? I bought it second hand in mint shape


    Sent from my iPhone using Tapatalk
     
    SkoldVape likes this.
  37. SkoldVape

    SkoldVape Silver Contributor

    Blog Posts:
    0
    Joined:
    Apr 10, 2017
    Messages:
    1,276
    Usually smok include a warranty card on the box, I got my replacement but they took the piss. The customer service is a nightmare is a nightmare man. Alot of Chinese companies are bad for it :(
     
  38. lcgixxer87

    lcgixxer87 Bronze Contributor Member For 2 Years

    Blog Posts:
    0
    Joined:
    Apr 7, 2015
    Messages:
    353
    Well after some more investigating it may be my merlin or the coils. I'm running some fused claptons. I took the atty right off and put it on my back up mod and it wouldn't fire. I took the cap off and pushed the coils in and it started to fire. The coils might be too big or shorting or something because my little eleaf 80w is solid. Over a year with no issues. I may need to downsize on coils a bit


    Sent from my iPhone using Tapatalk
     
    SkoldVape likes this.
  39. lcgixxer87

    lcgixxer87 Bronze Contributor Member For 2 Years

    Blog Posts:
    0
    Joined:
    Apr 7, 2015
    Messages:
    353
    Running dual 3mm coils 6 wraps, 26K 36Ni wrapped


    Sent from my iPhone using Tapatalk
     
    SkoldVape likes this.
  40. SkoldVape

    SkoldVape Silver Contributor

    Blog Posts:
    0
    Joined:
    Apr 10, 2017
    Messages:
    1,276
    PM me if your struggling at all :) your right though though ipower is great, I have the wood effect one! Anyway... if it's anything like the merlin mini it doesn't take massive builds as it's an MTL atty if I remember correctly
     

Share This Page

Close This Message