TFV 8 Baby Beast chimney problem

Discussion in 'Ask An Expert' started by OGNemo, May 17, 2017.

  1. OGNemo

    OGNemo New Member

    Blog Posts:
    0
    Joined:
    May 17, 2017
    Messages:
    5
    So I bought an Alien 220 kit with the Baby Beast from fasttech. Everything was great until I decided to change the preinstalled coil to the t8 that was included in the package. The top part was hard to unscrew as hell, saw that the chimney threads were damaged. After messing around for a couple of mins (the coil kept wobbling as the chimney part was not even) I managed to screw the coil to the top but it wasnt even as the chimney was tilted just a little bit to the other side (like half millimeter). Everything was fine and it didnt bother me. Next day the vape seemed almost without flavour and kept getting dry/semi dry hits. Bought new coils several times (tried the Q2 and the T8) but the problem prevailed. Contacted FT and they said to look for a replacement part and offered a 5$ refund.
    Any advice?
     

    Attached Files:

  2. fraleywp

    fraleywp Silver Contributor

    Blog Posts:
    0
    Joined:
    Feb 26, 2017
    Messages:
    1,107
    I would contact Smok. That looks like a defect in manufacturing to me.
     
  3. OGNemo

    OGNemo New Member

    Blog Posts:
    0
    Joined:
    May 17, 2017
    Messages:
    5
    Will Smok help me even if I did not buy from their website?
     
  4. fraleywp

    fraleywp Silver Contributor

    Blog Posts:
    0
    Joined:
    Feb 26, 2017
    Messages:
    1,107
    Yes they should.
     
  5. OGNemo

    OGNemo New Member

    Blog Posts:
    0
    Joined:
    May 17, 2017
    Messages:
    5
    Ok, will try, thank you :}
     
  6. OGNemo

    OGNemo New Member

    Blog Posts:
    0
    Joined:
    May 17, 2017
    Messages:
    5
    Ok, so I tried 50/50 base instead of using dripperbase (100vg) and the problem seemed to go away. But I still think Baby Beast should be able handle high vg base easily.
     
  7. cvcrcr99

    cvcrcr99 Bronze Contributor Member For 1 Year

    Blog Posts:
    0
    Joined:
    Jul 3, 2015
    Messages:
    447
    I typically use 70/30 or 80/20 juice in my baby beast without any issues. Just finished up using the "stock" x4 (?) coil which wasn't great. Anything above 45w it would dry hit until I poked holes into the cotton on the sides. Using the 6 coil one now (the other that comes in the box) and it works like a champ at 80-90w. Yes, I poked holes in the sides of the cotton on the 6 coil head before installing.

    Just ordered a pack of the 8 coil heads from FT. I expect to use that around 100w. Can't wait. Sorry to hear you are having trouble.
     
  8. voicenyerhed

    voicenyerhed New Member

    Blog Posts:
    0
    Joined:
    May 9, 2017
    Messages:
    18
    I'm also using the alien 220w with the baby beast. I've been using this for a few weeks now and have not had any issues with it. I am and have been running it at 45w with the V8-X4 coils. But suddenly today I seem to be noticing that the vapor feels as if it is forming condensation in the back of my throat and making me cough as a result. I don't know why this would be happening all of a sudden. At first I thought it might be from using a new juice that I began using yesterday, but I have changed back to the original juice I was previously using and the problem persists. I am getting great flavor and other than this annoying issue I have been super happy with this mod and tank. This is my first time using a real big boy set up and maybe this is normal? But I don't want to continue coughing every time I take a puff. Any suggestions?
     
  9. OGNemo

    OGNemo New Member

    Blog Posts:
    0
    Joined:
    May 17, 2017
    Messages:
    5
    Ok I tried 50/50 juice, poking holes but still no use. I think I'll just sell the atomizer, thanks for the help people.
     

Share This Page

Close This Message