Having issues with a VariAnt 250 clone.

I picked up the clone at a local vape shop called Inno-Vape, got it home and charged up. Now after getting it all put together, it wont fire and the screen doesnt light up. The battery charged for 4+ hours, so i dont think its the battery. Any suggestions?
 

Scooby

Member For 4 Years
Member For 3 Years
Member For 2 Years
Member For 1 Year
Member For 5 Years
You posted this in the wrong spot bud. This is for unregulated (mechanical mods). Should've posted in regulated but I'm sure one of the mods will move it about the same time I even post this.:)
 

st_andrew

Bronze Contributor
Member For 4 Years
Member For 3 Years
Member For 2 Years
Member For 1 Year
Member For 5 Years
Hold fire button and center button down to turn on
 

MKPM

AMG
Diamond Contributor
Member For 4 Years
Member For 3 Years
Member For 2 Years
ECF Refugee
Buy hammer
 

st_andrew

Bronze Contributor
Member For 4 Years
Member For 3 Years
Member For 2 Years
Member For 1 Year
Member For 5 Years
I've been eyeing this since late November . I just can't see myself paying over 150$, when I build my own mods. I'm thinking of just building a 3s or 4s pwm mod. Screw 260w I will just put down 600w. You think 16.8v is enough? Maybe I'll just do the 3s.
 
i know its a bit different then most mods with the 5 clicks on and off but the fire button and power/menu button are different
to lock and put in stealth mode you click center and fire button once for lock twice for stealth and 3rd time goes back to normal
 

VU Sponsors

Top