LostVape Drone 250c

Discussion in 'RECALLS, and Faulty Products' started by Big Jake, Apr 10, 2019.

  1. Big Jake

    Big Jake Bronze Contributor Member For 4 Years

    Blog Posts:
    0
    Joined:
    Jun 25, 2014
    Messages:
    213
    Need to keep an eye out on the new Loast Vape drones. 510 connector issues new out of box. Sent to Evolve for warranty repair and what I got back is the same as I sent except now the centerpin and 510 connector has gouges in them. Repair work looks like it consisted of someone using pliers and pulling the pin up. After placing rda back on after repair everything went right back to how it was out of the box new with the centerpin sitting very close to the threads. Looks like I have a new paperweight
     

    Attached Files:

    Theboss likes this.
  2. Theboss

    Theboss Silver Contributor ECF Refugee

    Blog Posts:
    0
    Joined:
    Sep 27, 2018
    Messages:
    505
    I'm not going to :deadhorse: I've already posted my disappointment with it a few times. I'll just add that I got rid of mine after 5 days.

    Weird though that the issues with the OG Drone, 510 and door, were not resolved with the new one. I own Therion's, a Paranormal and a Triade that are built very well with no issues at all. Obviously the company can make excellent products, I guess the Drone is their big fail.
     
    Big Jake likes this.
  3. Smiling Ogre

    Smiling Ogre Member For 1 Year

    Blog Posts:
    0
    Joined:
    Aug 18, 2017
    Messages:
    80
    Appreciate the post! Was eying this one as I have an old drone that is a fine mod. Guess I'll pass at least for now. I have quite a few Lost Vape mods and to date only had one problem. I got a Triade 250C and the seal behind the fire button was reversed in assembly causing the button to stick. It was about a three minute fix.
     
  4. Big Jake

    Big Jake Bronze Contributor Member For 4 Years

    Blog Posts:
    0
    Joined:
    Jun 25, 2014
    Messages:
    213
    I sent some "hate" mail to evolve (warranty repair in the US for lost vape) and told them just how disappointed I am in their shoddy work. Looks like I tear it apart myself and see if its just a crappy 510pin or if i need to replace the entire 510 connector. SOOOOO disappointed and was not expecting this from my first DNA device. Kinda feels like I bought something I-Joy related. on a side note I did pick up a athena mech squonk box and fallen back in love with mech box's and squonking simplicity at its best.
     
    Theboss likes this.
  5. tejas240

    tejas240 Member For 1 Year

    Blog Posts:
    0
    Joined:
    Jan 23, 2018
    Messages:
    76
    No just say Smok related, I have two I-joy mods both have worked flawlessly for a long time. ;);)
     
  6. Big Jake

    Big Jake Bronze Contributor Member For 4 Years

    Blog Posts:
    0
    Joined:
    Jun 25, 2014
    Messages:
    213
    Evolve did apologize. Thats was nice. However they had a chance to fix a mishap from factory assembly and failed so yes I took it apart to see just what was going on. What I found under the 510 connector was just tooooo much of everything. From excess squonk tubing to positive pin wiring all over the place. Trimmed off some tubing and re soldered the positive pin, carefully maintain some placement of said items while re assembly and now its looks great/ works great. No worries of shorts and the 510 pin is in fact spring loaded. The rda sits flush on the device now that the 510 can actually be installed flush. Easy Fix
     

    Attached Files:

  7. Smiling Ogre

    Smiling Ogre Member For 1 Year

    Blog Posts:
    0
    Joined:
    Aug 18, 2017
    Messages:
    80
    Glad to hear you were able to fix it however I can't agree that it was an "easy" fix. Trimming tube, soldering, and routing does not constitute "easy" in my books. Very disappointing to read per Lost Vape's design and assembly. No way should the user have to re-engineer the top end of the mod.
     
    jb58 and Theboss like this.

Share This Page

Close This Message