Mod won't turn on

Discussion in 'Regulated (Voltage / Wattage / 3.7v/ Temp Control)' started by LebDavid, Nov 2, 2016.

  1. LebDavid

    LebDavid New Member

    Blog Posts:
    0
    Joined:
    Nov 2, 2016
    Messages:
    7
    I just inherited my friend's iStick Pico 75w. I'm fairly new to vaping and I've been using it for the past week with no problems. Today as I tried to turn it on, nothing shows up on the screen and it doesn't turn on at all. I've tried 3 different fully charged batteries and I've tried my tank on a different vape. Everything is working fine but it won't turn on.

    Any help is appreciated

    Thank you.

    Sent from my SAMSUNG-SM-G928A using Tapatalk
     
  2. RatRacer

    RatRacer a touch oɟɟ VU Donator Gold Contributor Member For 2 Years

    Blog Posts:
    0
    Joined:
    Jan 15, 2016
    Messages:
    3,420
    Welcome to VU

    You are putting the battery in positive side down, correct?
     
  3. LebDavid

    LebDavid New Member

    Blog Posts:
    0
    Joined:
    Nov 2, 2016
    Messages:
    7
    Yes of course

    Sent from my SAMSUNG-SM-G928A using Tapatalk
     
  4. RatRacer

    RatRacer a touch oɟɟ VU Donator Gold Contributor Member For 2 Years

    Blog Posts:
    0
    Joined:
    Jan 15, 2016
    Messages:
    3,420
    Did you try to plug a usb in to get the display to light up?
     
  5. LebDavid

    LebDavid New Member

    Blog Posts:
    0
    Joined:
    Nov 2, 2016
    Messages:
    7
    Yea I plugged in a microusb and nothing happened. Left it in usb for 20 mins. Nothing happened

    Sent from my SAMSUNG-SM-G928A using Tapatalk
     
  6. Dagoroth

    Dagoroth Silver Contributor Member For 1 Year

    Blog Posts:
    0
    Joined:
    Oct 16, 2016
    Messages:
    612
    Make sure it is into a USB port that recognizes devices. I tried the front USB ports on my desktop and they only charge for some reason. I'm not able to update firmware with them. Try the USB ports on the back of the pc. I would Google your device for firmware updates also. Might also be a faulty fire button if your device powers on after five rapid clicks of the fire button. Sorry just naming random things I'd do.
     
  7. RatRacer

    RatRacer a touch oɟɟ VU Donator Gold Contributor Member For 2 Years

    Blog Posts:
    0
    Joined:
    Jan 15, 2016
    Messages:
    3,420
    The switch is probably the culprit.
     
  8. LebDavid

    LebDavid New Member

    Blog Posts:
    0
    Joined:
    Nov 2, 2016
    Messages:
    7
    I'll try plugging into pc when I have a chance. If it's the switch, is it fixable, how?

    Sent from my SAMSUNG-SM-G928A using Tapatalk
     
  9. Dagoroth

    Dagoroth Silver Contributor Member For 1 Year

    Blog Posts:
    0
    Joined:
    Oct 16, 2016
    Messages:
    612
    If the fire button is broken at the chip/motherboard level I wouldn't say it is fixable. But hopefully it's just stuck or maybe misaligned with the actual clicker on the motherboard. Taking the casing off to access the underlying parts will most likely be the best way to find out.
     
  10. HondaDavidson

    HondaDavidson Gold Contributor Member For 2 Years

    Blog Posts:
    0
    Joined:
    Mar 21, 2016
    Messages:
    3,744
    I've had this happen on mine, 3 times...... Not sure what causes it yet. Seems more like a battery recognition problem more than a Switch thing to me... Maybe a dirty contact? As the mod turns on when you insert a battery.. You don' t have to use the switch on battery install.

    The first time it happened I tried all 7 of my 18650 batteries. no go. Plugging it into the PC got it started. (3 being button tops that are too tall to screw the cap down completely. and are used in my mechs).
    The second and 3rd it started up after trying a different battery.

    Hasn't happened since I re-installed the original firmware. So it could be a software glitch.
     
  11. LebDavid

    LebDavid New Member

    Blog Posts:
    0
    Joined:
    Nov 2, 2016
    Messages:
    7
    I've tried plugging it into pc and eleaf's firmware upgrader doesn't even recognize that it's there so I think it's gone. Does anyone have any thoughts about http://www.eleafworld.com/istick-100w/? Thinking of getting it as a replacement.

    Sent from my SAMSUNG-SM-G928A using Tapatalk
     
  12. matp75

    matp75 New Member

    Blog Posts:
    0
    Joined:
    Nov 3, 2016
    Messages:
    55
    I just bought two istic pico 75s last week one for me and one for the wife. mine is doing te same thing. I took the battery out of mine put in hers hers works fine. maybe my local shop will take it back for credit or something.

    edit: just plugged it in my laptop it shows up and screen comes on ugraded the firmware seems to be working again dunno
     
    Last edited: Nov 4, 2016
  13. matp75

    matp75 New Member

    Blog Posts:
    0
    Joined:
    Nov 3, 2016
    Messages:
    55
    posted edit above...
     
    Last edited: Nov 4, 2016
  14. LebDavid

    LebDavid New Member

    Blog Posts:
    0
    Joined:
    Nov 2, 2016
    Messages:
    7
    Yea that was the first thing I tried.. hasn't recognized it at all so just ordered the mod I linked above. Should be here soon

    Sent from my SAMSUNG-SM-G928A using Tapatalk
     
  15. matp75

    matp75 New Member

    Blog Posts:
    0
    Joined:
    Nov 3, 2016
    Messages:
    55
    cool. glad mine came back i like it as dailey user. I save my reuleaux200s for the house and my tfv8 tank
     
  16. matp75

    matp75 New Member

    Blog Posts:
    0
    Joined:
    Nov 3, 2016
    Messages:
    55
    just as a check if i take my battery out and put it back in i have to plug it in to make it work again
     
  17. matp75

    matp75 New Member

    Blog Posts:
    0
    Joined:
    Nov 3, 2016
    Messages:
    55
    hey lebdavid try this I just did it with mine... I took the battery out put it back in and it didnt work. I light tamped it against my hand and it popped on
    *edit mine finally kicked the bucket only two weeks old wonder if my local shop will hook me up
     
    Last edited: Nov 4, 2016
  18. LebDavid

    LebDavid New Member

    Blog Posts:
    0
    Joined:
    Nov 2, 2016
    Messages:
    7
    Tbh that was one of the things I tried cuz most things tend to work after a good hit haha. I think it's a lost cause at this point..

    Sent from my SAMSUNG-SM-G928A using Tapatalk
     
  19. siegevape385

    siegevape385 New Member

    Blog Posts:
    0
    Joined:
    Jul 7, 2018
    Messages:
    1
    my sigelei kaos spectrum is doing this aswell, it works when plugged into a pc or usb but as soon as its off the usb it turns off and wont turn on. Any ideas on whats going on with my vape ive had 4 different vapes none have done this so far. im thinking maybe its a software glitch.
     
  20. SteveS45

    SteveS45 Diamond Contributor Member For 2 Years ECF Refugee

    Blog Posts:
    0
    Joined:
    Mar 25, 2016
    Messages:
    12,129
    In the Automotive World that is known as the Technical Tap~!
     
  21. Ralph_K

    Ralph_K Bronze Contributor

    Blog Posts:
    0
    Joined:
    Jan 7, 2018
    Messages:
    278
    I got a istick 100w 21700 and the fire button sticks. Didn't you know that is why they call it an istick.
     

Share This Page

Close This Message