Nitecore UM20 not charging one side

Discussion in 'Chargers' started by RenoMama, Oct 3, 2015.

  1. RenoMama

    RenoMama Silver Contributor Member For 1 Year

    Blog Posts:
    0
    Joined:
    Sep 18, 2015
    Messages:
    737
    I picked up a Nitecore UM20 exactly three weeks ago. I've been using it probably every other day, overnight to charge batteries. This morning I had a flashing error code. One battery was charged to 91% the other to 65%. They were at 50% when put on to charge so it's safe to say the error popped up not long after starting to charge. At this point it seems only the left slot of the charger is working. Has any one else had a problem like this or been able to resolve it? I went on their website and couldn't find anything relevant. I'd hate to throw this thing away after 3 weeks of use.
     
  2. Angrygod50

    Angrygod50 Gold Contributor Member For 2 Years

    Blog Posts:
    0
    Joined:
    Sep 21, 2015
    Messages:
    1,812
    Sounds like the charger went bad but first try a different wall adapter. Nitecore has a 12 mo warranty according to there web site so I'd check with who you got it from to see if they will exchange it. I've been using an I2 for over a year with no problems. (Vaping and flashlights)
    If you need to get a new one look at Liionwholesale.com. Jon is an active member here and has fantastic service and prices. Lots of folks here love the efest chargers. He has both brands.
     
    RenoMama likes this.
  3. RenoMama

    RenoMama Silver Contributor Member For 1 Year

    Blog Posts:
    0
    Joined:
    Sep 18, 2015
    Messages:
    737
    I didn't think about the wall adapter. My kids took the one I usually use and I used an apple wall plug. It's working fine now. I'll keep that place in mind for the future though. Thanks for the help!
     
    JuicyLucy likes this.
  4. Angrygod50

    Angrygod50 Gold Contributor Member For 2 Years

    Blog Posts:
    0
    Joined:
    Sep 21, 2015
    Messages:
    1,812
    Glad it worked out. The apple wall wart is 2Amp nitecore wants .5 to 1A (500ma to 1000ma)
     
  5. RenoMama

    RenoMama Silver Contributor Member For 1 Year

    Blog Posts:
    0
    Joined:
    Sep 18, 2015
    Messages:
    737
    I see. Really wish they would have just included one with the charger to simplify things. Thank you for the info. I'll be sure to check the wall adapters before use.
     
  6. Joshua Iles

    Joshua Iles Gold Contributor Member For 2 Years

    Blog Posts:
    0
    Joined:
    Dec 7, 2014
    Messages:
    1,524
    I noticed on my um10 sometimes if the battery isn't sitting in there well it won't charge, also depends on the wall plug as well. Mine the plastic has started cracking and I have no clue what's up with that. Not in a place where its going to affect anything, I may have just dropped it one too many times.
     
  7. RenoMama

    RenoMama Silver Contributor Member For 1 Year

    Blog Posts:
    0
    Joined:
    Sep 18, 2015
    Messages:
    737
    I've been using a Samsung wall plug that came with a Galaxy tablet, haven't had an issue since then. But now it doesn't seem like my batteries are lasting as long as before. Grrrrr....
     
  8. Joshua Iles

    Joshua Iles Gold Contributor Member For 2 Years

    Blog Posts:
    0
    Joined:
    Dec 7, 2014
    Messages:
    1,524
    Try letting them sit on the charger a little longer, found with my 10 that seemed to help. I have an xtar charger coming in the mail soon and that may be another option for ya if the nitecore has pooped, I ordered an mc2 for about $10. We'll see if it's any better. Sorry you're having issues.
     
    RenoMama likes this.
  9. RenoMama

    RenoMama Silver Contributor Member For 1 Year

    Blog Posts:
    0
    Joined:
    Sep 18, 2015
    Messages:
    737
    Thank you for the tip. I'm going back and forth now if it's charger or batteries. I suppose there's only one way to find out, buy new batteries or a new charger. It's bearable for now, just a little frustrating since it's all relatively new gear.
     
  10. Heather0069

    Heather0069 New Member

    Blog Posts:
    0
    Joined:
    Mar 1, 2016
    Messages:
    1
    I'm so glad I found this page. I was having the exact same problem. Very frustrating! I just switched the wall plug to my Samsung one and it works perfectly fine. Hope this helps others too.
    Happy vaping :)
     
  11. RenoMama

    RenoMama Silver Contributor Member For 1 Year

    Blog Posts:
    0
    Joined:
    Sep 18, 2015
    Messages:
    737
    My charger gave out a little while after this post. nothing but error codes ten minutes into every charge no matter what wall plug I used. Hope it works out better for you. Pretty hair by the way!
     
  12. freemind

    freemind Gold Contributor Member For 2 Years

    Blog Posts:
    0
    Joined:
    Nov 24, 2014
    Messages:
    4,477
    I questioned folks about the other chargers, made by Nitecore. I had a 2 bay and a 4 bay shit out on me.

    From now on, I'll likely buy a Xstar charger. It doesn't appear that Nitecore makes quality chargers.
     
  13. RenoMama

    RenoMama Silver Contributor Member For 1 Year

    Blog Posts:
    0
    Joined:
    Sep 18, 2015
    Messages:
    737
    I ended up with another nitecore (d2 digicharger) that I've had for a few months now. For some reason it seems that's all the shops around here carry. Haven't had any issues so far. Keeping my fingers crossed.
     
  14. freemind

    freemind Gold Contributor Member For 2 Years

    Blog Posts:
    0
    Joined:
    Nov 24, 2014
    Messages:
    4,477
    I too, bought a D4. The "I" series of chargers, are just not durable.

    For what I have spent in the last two years on chargers, I could have bought a Xstar. I'll never buy another Nitecore product, if this D4 doesn't last a year.
     
  15. RenoMama

    RenoMama Silver Contributor Member For 1 Year

    Blog Posts:
    0
    Joined:
    Sep 18, 2015
    Messages:
    737
    I'll be sure to keep that in mind if this one craps out on me too. The last one only lasted a couple months.
     
  16. BoroFan11UK

    BoroFan11UK New Member

    Blog Posts:
    0
    Joined:
    Jan 12, 2017
    Messages:
    1
    Ive just came across the nitecore um20 and ive had it for over a year i also got the 4 port one but ive just tried the 2 port and all i get is a little light on it does not shur anything else. Could someone please help. Thank you
     
  17. samlock

    samlock New Member

    Blog Posts:
    0
    Joined:
    Jul 5, 2017
    Messages:
    1
    I recently started using UM20 charger to charge my batteries. So the charger charges Samsung 25R - 65% & LG HG2 - 77% post which it just stalls. Just to see I left LG HG2 for a little longer, apparently the LCD on UM20 started blinking and the battery was damn hot. Is there a problem with my charger or a problem with the Wall Plug? using original Samsung USB with the wall mount.
     
    Last edited: Jul 5, 2017

Share This Page

Close This Message