1. UP FOR A NEW CHALLENGE? CLICK HERE TO CHECK IT OUT

Provari P3 problems

Discussion in 'Regulated (Voltage / Wattage / 3.7v/ Temp Control)' started by Terminalintel, Jun 15, 2015.

  1. Terminalintel

    Terminalintel Member For 3 Years

    Blog Posts:
    0
    Joined:
    Jun 14, 2015
    Messages:
    110
    So I've had my provari P3 for a few weeks now, but neigh, I'm having problems with it... Hourly. The battery some how always reads at a poor IQ causing me to have to remove the battery and replace it. I've ran IMR 18650 with the button top, and Samsung 18650 flat tops and both always have the problem. The IMR not as frequent. I've also noticed if it goes in my pocket, it ALWAYS has an error message. I'm starting to be very upset with this product. For such a very beautiful mod, and superb quality, this is disappointing. I'm still on V.36 I haven't had a chance to update it to v.38, maybe that is where most my problems lie?

    P.S. I'm running 19w at 4.7v with a kanger sub tank 1.2ohm coil on 3 boost.
     
  2. VapinMoody

    VapinMoody Member For 3 Years ECF Refugee

    Blog Posts:
    0
    Joined:
    Jan 2, 2015
    Messages:
    70
    @Terminalintel--Go on Provape's website and email them.....they will respond if you request a help ticket fairly quick....good people and great product...
     
  3. Fictitious Character

    Fictitious Character Silver Contributor Member For 3 Years

    Blog Posts:
    0
    Joined:
    Sep 24, 2014
    Messages:
    1,449
    More than likely you need a spring replacement. Some others were having similar issues and provapes solution was a thicker spring. I would do as suggested and contact provape.
     
  4. Terminalintel

    Terminalintel Member For 3 Years

    Blog Posts:
    0
    Joined:
    Jun 14, 2015
    Messages:
    110
    I emailed them, I hope it's not that, I already waited a month for it because of them putting down the wrong address twice.
     
  5. Terminalintel

    Terminalintel Member For 3 Years

    Blog Posts:
    0
    Joined:
    Jun 14, 2015
    Messages:
    110
    Got a hold of provape. Said I do in fact have the new spring, they think it's the old version and advices me to update and report back if the problems persist. They assured me all the problems should go away, and if not they want me to send it back for a thorough diagnostic. Hopefully have it replaced within a week (if that were to happen)
     
  6. st0nedpenguin

    st0nedpenguin Bronze Contributor

    Blog Posts:
    0
    Joined:
    Apr 13, 2015
    Messages:
    348
    Are you sure your batteries just aren't bad?
     
  7. Terminalintel

    Terminalintel Member For 3 Years

    Blog Posts:
    0
    Joined:
    Jun 14, 2015
    Messages:
    110
    My red IMR are brand new. The samsungs are probably bad as I've been running them for about a year. But they work in my segelei 20w
     
  8. st0nedpenguin

    st0nedpenguin Bronze Contributor

    Blog Posts:
    0
    Joined:
    Apr 13, 2015
    Messages:
    348
    It's totally dependent on what cells the "red IMR" batteries are though.
     
  9. Terminalintel

    Terminalintel Member For 3 Years

    Blog Posts:
    0
    Joined:
    Jun 14, 2015
    Messages:
    110
    Pulled from provapes website:

    • 2200 mAh
    • Nominal Working Voltage: 3.7V
    • Peak Voltage: 4.2V
    • Dimensions: 18D x 65H mm (+/- 0.5mm)
    • Weight: 40 (+/- 2) g
     
    Last edited: Jun 16, 2015

Share This Page

Close This Message