RDA Help

Discussion in 'General Rebuildable Discussion (RTA/RBA/RDA)' started by Brock.G, Jan 9, 2017.

  1. Brock.G

    Brock.G New Member

    Blog Posts:
    0
    Joined:
    Jan 9, 2017
    Messages:
    1
    I've been vaping for about a year now. However, I have always used a tank atomizer when vaping. A lot of my friends vape off of RDA's so I figured I would give it a shot. A few days ago I bought a Velocity V2. I rigged it up with clapton coils that read right around .2 ohms. I primed the coils just like you are supposed to and when to vape and got this crazy burnt taste. Now having been vaping for awhile i knew that this wasn't good obviously. However in a tank it just means you need a new coil. But having the brand new coils. fresh wick, and new rda I have no clue whats wrong. Ive tried re-wicking it a million different ways with shorter and longer tails and still nothing. I have no idea what is wrong and the only conclusion i can come to is the coils? Any help or suggestions to what the problem is would be greatly appreciated!

    -Brock
     
  2. SirRichardRear

    SirRichardRear AKA Anthony Vapes on Youtube VU Donator Diamond Contributor Member For 1 Year Reviewer

    Blog Posts:
    0
    Joined:
    Jul 8, 2016
    Messages:
    10,864
    did you remove hot spots and make sure your coils aren't touching any metal? pics of the build would go a long way as well
     
    Klove1337 likes this.
  3. Klove1337

    Klove1337 New Member

    Blog Posts:
    0
    Joined:
    Jan 9, 2017
    Messages:
    40
    Take out the cotton, go to YT. Profit :)
    Its probably the wick, or the coils.
    You need to go to youtube and get advice :)
     

Share This Page

Close This Message